XLH Speedometer Preliminary Diagnostics

Not open for further replies.
I finally got some time to tend to my 2000 XLH 883 speedo/turn signal problem. First thing, checked to see if connectors under the seat were re-connected. Everything appeared to be connected. However, when I was "learning" how to get the speed-sensor connector free of the frame, I disconnected it, despite it being a lock-type of connector. I pushed it back together to connect it properly, and then tried to just pull it apart, which it won't do.
Perhaps, THAT was the problem. Or, maybe my thumb pressed that little button.

Continuing with preliminary diagnostics, I disconnected the speed-sensor again, and took DC volt readings across the connector's speedo-side red-to-black pin holes, and across red-to-frame, getting 10.26 Vat each condition.

Next, I utilized the speedo's self-diagnostic function, and following the book's directions, obtained the following codes and status indicators:

d01 CLr
d02 SEt
d03 (thru d09) CLr
d10 SEt
CAL 14

Per the book, the d02 code indicates "speed sensor power output shorted high or open" and the d10 code indicates "speed sensor output shorted low or open".

At this point, the following is true (although, I didn't ride the bike after tests up to this point): (1) speedometer is inoperative,(2) backlighting works with ignition switch ON, (3) I cleared the codes and then verified the codes were not present, and (4) speedo was returned to normal, back tire was rotated 4 revolutions with ignition ON, diagnostic mode was enabled, and there were no codes present.

Book says further testing with a H-D speedometer tester is required at this point. Is there something I did incorrectly? Is there more I can do? I'll ride the bike tomorrow , to see if I lucked-out and "fixed" anything.
Last edited:
Is yer problem fixed yet? If not, check to see that the Coil or the Plug Wires are not near ANY of the wiring, Ignition interferance will make the speedo do weird stuff, and you will get a Diag Code for the VSS,
I believe problem has been solved.But seem he dont update the thread.
Thread Closed!
Not open for further replies.