Temp. light and CEL

Discussion in 'Touring Models' started by D.Bradfield, May 12, 2019.

  1. D.Bradfield

    D.Bradfield Active Member Contributor

    153
    38
    22
    Took an 1800 mile round trip out to see my Marine, daughter in law and grandson on the 2014 Ultra Limited. Headed home and when I got about 250 miles from the house Temperature light and checked engine light lit up the dash. I pulled into a feed store out in the middle of nowhere and looked it over. It did have an overheating smell but the coolant reservoir was full. The coolant pipes going to the heads were cold. Pulled the code and it is a P1019 which is a default in the cooling system. Reset the codes and me and the wife were off. About 3.5 miles later it came back on. I pulled into a truck stop and told the wife that I wasn't sure what to do but needed to do something. Found a fellow biker at the gas pumps and discussed my issue. After Googling the code and doing the fan and pump test I decided to look for a dealer and the nearest one was in Jackson Ms. about 150 miles off my path. I called and talked with the service guy about what it could be and a plan. He made me feel somewhat comfortable about riding on and not getting in stop and go traffic. This is still a 90% air cooled engine! I got it home and my water pump doesn't seem to be running. I have voltage but it doesn't seem to be running. Harley has decided to build an upgraded one that is a 255 kit. No thermostat on the new one and from what I read it is either the same on the M8's or similar. Bike just rolled over 15k miles. Anyone else have this issue? I read where the Rushmore 14-16 models have had issues with the water pump. Also looking for a good online dealer recommendation to buys parts from.
     
  2. Harttoo

    Harttoo Well-Known Member

    2,725
    103
    254
    Water pump failure is common.Some have had more than one pump failure.Newcastle HD sells at 20%off online.
     
    D.Bradfield likes this.
  3. Breeze3at

    Breeze3at Experienced Member

    5,014
    153
    259
    I have read of several water pump failures that continued to be ridden with no engine damage.
     
    D.Bradfield likes this.
  4. D.Bradfield

    D.Bradfield Active Member Contributor

    153
    38
    22
    After looking at their website and doing a parts request for a quote from both Newcastle HD and my local HD dealer I ordered the new pump and a service manual from Newcastle. Was quoted at $255 from Newcastle and $352 from my local dealer. Amazed at the mark-up!!!