Radio doesnt play

Discussion in 'Communications And Radio' started by JaxHenrik, Jun 24, 2017.

  1. JaxHenrik

    JaxHenrik New Member

    1
    1
    0
    Hi all- Just lately, when I start the bike up, the radio wont power up. If I go down the road to get gas or go the store, the radio works when I start the bike to come home. Its happened more than a few times. Sound familiar? Any ideas? Thanks in advance.
     
  2. tourbox

    tourbox Senior Member Contributor

    2,014
    83
    206
    Sounds like a loose connection somewhere.
    tourbox
     
  3. Coodaddy

    Coodaddy New Member

    2
    1
    0
    I have an 08 Street Glide recently purchased and I drove 4 miles everything worked returned home and the radio, signals and horn stopped working. Parked it and returned to it later in the evening and it all worked again. Has anyone encountered this and what should I do?
     
  4. joel

    joel Senior Member

    1,278
    83
    206
    Does wiggling the switch seem to help any?
    I had a 03 RKC that had the harness to the switch begin to un plug and caused problems
     
  5. CRCKR

    CRCKR Active Member

    200
    48
    27
    This happens on my brand new SG too. Once or twice a week when I start the bike up the radio doesn't turn on. Have to turn off the ingnition and when it is turned back on the radio comes back. IT doesn't bother me too much but I'll get it to the dealership out of principal (and I don't just mean the principal on the loan!)
     
  6. joel

    joel Senior Member

    1,278
    83
    206
    On my 2015, the dealer did a update to the radio that has taken care of radio.
    Mine started out with no volume control that led to no radio operation until I would pull over and shut off the bike, wait about 10 seconds and restart.
    Also makes the warning message go away automatically after enough time to read it real slow.
     
  7. dirtchief686

    dirtchief686 New Member

    1
    11
    0
    sounds like a typical "boom" audio system to me. these things have a mind of their own. mine will come on when the bike is turned off, or turn off when the bike is on. go figure.
     
  8. Blue Wide Glide

    Blue Wide Glide Junior Member

    630
    48
    65
    I think you need a new gremlin bell!!:D
     
  9. liquid_wrench

    liquid_wrench Junior Member

    403
    38
    62
    My Radio doesn't come on sometimes....I thought it was the stock radio so I installed a Kenwood last winter....Guess what? It does the same thing....I just detatch the face and put it back on, then it's fine......lol
     
  10. Harttoo

    Harttoo Well-Known Member

    2,586
    83
    209
    Loose connection some place.If it has a fairing,remove fairing and unplug all radio connectors and plug back in.