2017 Ultra radio issues

Discussion in 'Communications And Radio' started by Rocrider50, Aug 1, 2017.

  1. Rocrider50

    Rocrider50 New Member

    3
    1
    0
    Well I have had a string of electrical codes on my new 2017 Ultra limited that led to a dead battery and a ABS module replacement. During all of this the radio stopped working on several levels. First the sound quality went hollow, tinny, no mid-range is the best I can explain. Wife won't let me play the radio when she's on the bike because it is so bad, and she always has music playing. Then along with my other electrical issues the radio stared cutting out on long rides over 2 hours. And when is say cutting out, its more like you are slowly going further from a station and it progressively cuts out. But I am listening to SIRUS radio in the open. I have the latest software, the bike has been reset and three dealers have looked at the radio. Still nothing. GPS is working fine as are the other features. Drove on a long two weeks trip with hollow sounding radio. Came home, washed cloths and went for another week but left in the rain. In the overnight (while washing cloths ) the battery died and would not jump start, got another battery and was fine. Departed for second week in the rain and check engine light came on. Set 10-12 codes, mostly U codes. ECM replaced then ABS module. No codes after ABS replaced, meanwhile dealer called and original battery OK. Dealer says nothing wrong with radio?
     
  2. Harttoo

    Harttoo Well-Known Member

    3,688
    133
    604
    Wow! Never heard anything like this.If the original battery was OK.Why did They replace it?Sounds like an intermittent problem.Hope They can make sense of this soon.
     
  3. flusher

    flusher Junior Member

    403
    38
    53
    Welcome, sorry to hear about your bike troubles, hope they get ironed out.
     
  4. tourbox

    tourbox Senior Member Contributor

    2,014
    83
    209
    Welcome from So.Texas. That does seem like a lot of problems.
    tourbox
     
  5. Rocrider50

    Rocrider50 New Member

    3
    1
    0
    Called Harley on this and they suggested I take it to another dealer. No one willing to help fix it.
     
  6. Harttoo

    Harttoo Well-Known Member

    3,688
    133
    604
  7. Rocrider50

    Rocrider50 New Member

    3
    1
    0
    Already tried that. I'm on top on the software updates. Uploaded the 1.21.04 the uploaded it again from the same thumb drive the down loaded it again for good measure, then the dealer reloaded it because they could. Tried to charge me $82 for doing it too. I also followed the "reset" procedure that sends everything back to factory settings. I need to get a hold of the radio manufacturer.
     
  8. tourbox

    tourbox Senior Member Contributor

    2,014
    83
    209
    Being it's a 2017 isn't it under warranty. I would take it back to dealer and tell them to replace it or keep the bike.
    tourbox
     
  9. Jeff Klarich

    Jeff Klarich Experienced Member Contributor

    6,276
    233
    1,045
    +1 on what tourbox suggested. You spent a lot of money to have it not work properly no matter what the dealer says.
     
  10. joel

    joel Senior Member

    1,993
    133
    562
    Maybe a new dealer is where you should go to get to the bottom of this, my local dealer did the radio update a couple weeks ago, service writer had the flash drive in his pocket, seems to have corrected a couple issues I had and they do if free.