Question about check engine - 2011 Softail

Discussion in 'Softail Models' started by vanzant68, Jul 7, 2011.

  1. vanzant68

    vanzant68 Member

    6
    0
    0
    I have a 2011 Softail Heritage Classic. Rode today with no problems, it was very hot out. This evening the bike started fine, however the check engine light and a little red light (electric / security system - according to manual, which my bike doesn't have) were both solid lit after starting bike. Any ideas on what the problem might be?
     
  2. dbmg

    dbmg Guest

    Re: Question about check engine - 2011 Softial

    Start at checking battery cables for tightness on both ends.
     
  3. glider

    glider Veteran Member

    25,464
    108
    49
  4. vanzant68

    vanzant68 Member

    6
    0
    0
    how do you "run diagnostics"
     
  5. glider

    glider Veteran Member

    25,464
    108
    49

    If you look at the link in post #3 you'll see how to do it.
     
  6. vanzant68

    vanzant68 Member

    6
    0
    0
    Thanks for helping out with comments. I ended up swinging by a dealer and they said codes (that they found) had something to do with (DMI or something that's new in 2011). Essentially the code indicated that there was a brief loss of communication between turn signal (and such) buttons and the brain of the bike. They cleared it, test drove it, and said I was good to go. If it reoccurs they said to bring it back and they would dig deeper.
     
  7. poohbear

    poohbear Active Member

    193
    28
    3
    2011 why not?? tell them you want one!