Help with codes

Discussion in 'Touring Models' started by 1bdi, Feb 22, 2010.

  1. 1bdi

    1bdi Member

    OK! I got the codes out of my 08 ultra classic. And they are...
    P-no rsp,
    S-none pn68920-07,
    SP-U1064 end pn67349-08, Loss of TSM/FSFM serial data to ECM
    l-U1040 U1255 end pn67348-04d, ???, Serial data error
    b-no rsp .
    From this I am assuming that there is a loose connection somewhere. I haven't been able to find out what U1040 is?? I think I'll have to remarry the TSM?
    Any comments would help!
  2. Chopper

    Chopper Senior Member

    Ok Rick, this is what I come up with.

    P-no rsp, no tach?

    S-none pn68920-07, - good security -tssm

    SP-U1064 end pn67349-08, Loss of TSM/FSFM serial data to ECM -speedo
    A DTC U1064 indicates that there was communication on the data bus since power up, but was lost or interrupted during that key cycle

    l-U1040 U1255 end pn67348-04d, ???, Serial data error (T) -TACH
    A DTC U1255 (only reported by the TSM/TSSM/HFSM or speedometer) indicatesthat no messages were present during power up of the current key cycle.

    b-no rsp - no abs brakes on bike

    How's the wow test?
    are there any problems with the bike? is the tach working?
    can find no u1040 for a 08
    how about a little history
    Clear all codes, start the bike, shut off and check again
  3. 1bdi

    1bdi Member

    I drove the bike on the trailer at the used car dealers, it had a 2 1/2 hour ride home. The last 20 minutes was on a plowed but unsalted road that was a bit rough. When it came off the trailer I tried to start it but all I got was a red key on the speedo. I was told it didn't have a security system and didn't need a fob? Haven't got any manuals yet so I'm fly'n blind. It has cruse and ABS.
  4. Chopper

    Chopper Senior Member

    When you turn the ign on what does the engine light do #7, is the stop/run switch set to run?



    To diagnose TSM/HFSM system problems, begin by observing the behavior of the security lamp.


    • To provide an indication of HFSM DTCs, the security lamp is enabled on HFSM models.

    • "Key ON" means that the ignition switch is turned to IGNITION and the engine stop switch is set to RUN (although the engine is not running).

    • When the ignition switch is turned to IGNITION, the check engine lamp will illuminate for approximately four seconds and then turn off.

    • If the check engine lamp is not illuminated at IGNITION ON, the problem is likely to be an instrument failure.


    • If the security lamp fails to turn OFF after the initial four second period, a problem exists in the instrumentation.

    1.After the security lamp turns off following the first four-second illumination period, one of three events may occur:

    a. The lamp remains off. This indicates there are no current fault conditions or stored DTCs currently detected by the HFSM.

    b. The lamp stays off for only four seconds and then comes back on for an eight-second period. This indicates a DTC is stored, but no current DTC exists.

    c. The lamp remains on beyond the eight-second period.This indicates a current DTC exists.
  5. 1bdi

    1bdi Member

    Found a blown fuse!
    Ignition fuse,15a. Had been replaced with a 30a (30a was cooked)
    Replaced it with a 15a, all lights in the WOW test light up except the low fuel?
    Ran the codes again:
    P- none
    S- none
    SP- u1064
    T- u1040, u1255
    B- none
    Same as before but now everything replies. When the ignition is turned on the security light goes out the only thing is the abs flashing. Tried to start it and the ignition fuse blew. Going to get more fuses !?
    Any thoughts??
  6. Chopper

    Chopper Senior Member

    Did you clear the codes then cycle the ign to see what codes came back?
    A 30a fuse in a 15a hole means someone had a problem before, but now you at lease have a place to start looking.
    the low fuel should light up in the wow test.
    does the bike have abs, seem I remember the abs flashes on abs bikes untill it rolls and sends a signal to unit.
    where did you have the straps connected when you trailer it, something is grounded in the ign circuit as you found, maybe a wire close to were it was tied down?
    if right hand control was maybe turned could have caused a short under the clamp to starter wire past button?
    let us know what you fine, and instead of blowing fuses if you have a multi tester you can check the fuse term for a ground.
    good luck
  7. 1bdi

    1bdi Member

    Put in a NEW 15a fuse and she started!! (yah!)
    Let it run for a minute...30+ oil pressure...14+ volts ....1/3 tank of gas and the air temp didn't move (its -8 celsius here thats about 17.5 F)
    So I shut it down, cleared the codes, ran it for a few minutes then read the codes again! They all came up "none"!!!
    Time for a three finger shot!!
    I would like to know what the u1040 code is???
    Before the season starts I'll go over everything with a meter. Like you said someone had a problem!
    Thanks for all your help! I wouldn't have figured it out without this site!!

  8. Chopper

    Chopper Senior Member

    That's way cool, get yourself the service manual & the diagnostic manual, there's a lot of wires on them ultra's.
    Harley does not show any u1040 code but what I found on the net from auto codes was
    U1040 Serial Data error-
    U1040 SCP (J1850) Invalid or Missing Data for Vehicle Speed

    The new systems can throw false codes sometime, if someone was installing or working on something and cycled the ign, that could have poped the codes, you might never see it again. But while on the trailer something happen to short that fuse, look for a pinched wire.
    Ride safe & cheers
  9. jaceddie

    jaceddie Junior Member

    Chopper, I have an 09 UC with 20k miles. About a week ago I had no throttle at start up with the check engine light. After restarting a couple of times, the throttle started working. Checked the codes and had P1511 and P2135. Rode the bike for a few days and everything seemed fine, so I cancelled out the codes. Today, about a mile from the house, the throttle quit working again and the check engine light came on. After limping home, I checked the codes again and had P rSP. After starting the bike, the throttle started working again. I have an appointment with my dealer for the 24th, but I'm a little worried that my bike will be laid up for a part or something. We are leaving for a trip to the west coast on the 30th and will be gone for a month. Is there something I can check or do? Thanks.
  10. genodgeno

    genodgeno Member

    u1040 ABS communication lost??

    What I found was that U1040 in a Caddy says "loss of communication with ABS". Well I plugged my fuse back in and the code cleared.

    I have my ABS fuse pulled cause I hate it. Don't wanna start that debate. There are enough threads on the subject for that.

    2008 Ultra 105th