Battery Seems Weak

Discussion in 'Electrical' started by joel, May 31, 2019.

  1. joel

    joel Senior Member

    1,424
    103
    270
    I have the 2015 CVO Limited, getting reading for a road trip and while not having any real change in the way the starter cranks the engine, it has always had a slight drag at the beginning of crank, I thought I would check the battery and charge rate.
    These are after the bike sat for 6 + hrs measured at the remote trickle charger connection
    Key off 12.85 volts
    Key on engine off 12.34 voltage
    Cranking voltage 8.35
    Idle charge rate 13.82 [ did not raise RPM after start up ]
    2500 RPM charge rate 14.02
    Idle charge rate 14.02
    Cold Cranking amps rating is 385, tested at 335, at the battery
    Getting the 500 cold cranking amp battery on it's way
    I can't post in the self help section so hope this is the right category
     
  2. Breeze3at

    Breeze3at Experienced Member

    5,031
    153
    264
    Good post, thanks. That 3-4 yr.old battery owes you nothing. The new one will spin the motor better, and you won't have the worry of a dead battery on your trip.
     
  3. gator508

    gator508 Well-Known Member

    3,165
    103
    358
    I'll echo what Pete says, you never know when a battery will start going bad, better to invest in a new one
     
  4. joel

    joel Senior Member

    1,424
    103
    270
    Replaced the battery yesterday.
    2 things.
    The OE battery is rated at 405 cca. My statement of 385 was from a battery book
    2 nd it starts so much better now.
     
  5. jamesearl

    jamesearl Senior Member

    2,443
    103
    384
    Regular or lithium battery?
     
  6. joel

    joel Senior Member

    1,424
    103
    270
    Installed AGM type from Interstate.
    1559656826814144223787895067356.jpg
     
  7. Blue Wide Glide

    Blue Wide Glide Junior Member

    643
    48
    68
    Few things are as annoying as wondering if your battery is OK.:mad:
     
  8. biscuit

    biscuit Junior Member

    609
    48
    29
    Time for a new battery.
    If your battery drops below 10 Volts when cranking it’s not doing the job.
    Your no-load Volts at12.85v are good: your “key on” Volts are somewhat low, but your charging Volts seem to be as expected. That is:satisfactory.
    Load test your battery- but as mentioned if it’s dropping to 8 Volts then it can’t even power up your ECU or ignition system.
    Is it still the 2015 battery that came with the bike? If so, it’s had its day and now it’s due to meet its replacement.